File Menu

The HM3 File Menu allows you to:
  1. Create a New Database
  2. Open an Existing Database
  3. Import Files (Hand History Files)
  4. Import Folders (Hand History Folders)
  5. Import a HM2 Database
  6. Start/Stop Auto Import
  7. Switch to a Recent Database
Suggested Video Guides


1. Create a New Database

New Database allows you to start with a brand new database with no hands imported. HM3 will open a Windows File Explorer window where you type in the name of your new database, then click Open.

Creating a new Holdem Manager database

HM3 Databases are stored in the Documents folder on your PC:
C:\Users\Your PC Name\Documents\Holdem Manager 3\Databases

For best performance: Create your HM3 database on the primary hard drive where Windows is installed. (Usually your "C" drive.)

- DO NOT CREATE HM3 Databases in a sub-folder on any cloud file hosting service (Dropbox, OneDrive,.Google Drive, etc) as it will cause database corruptions if synchronizing while HM3 is running.  

- DO NOT CREATE HM3 Databases on USB/external hard drives. This can severely slow down Holdem Manager 3 performance. Holdem Manager 3 uses your HM3 Database for just about every operation you perform in HM3.


2. Open an Existing Database

Open Database allows you to open a preexisting database. HM3 will open a Windows File Explorer window where you select the HM3 database you want to open.

Opening a saved database


3. Import Files (Hand History Files)

Import Files lets you manually import hand history files. HM3 will open a Windows File Explorer window where you select the hand history files you want to import. Select the file(s), then click Open.

Importing hand history files.

HM3 will auto import hand history files as you play poker.  The only time you need to manually import hand history files is when:

  • You created a new database.
  • Your poker site sent you old hand history text files.
  • Re-import hands after a HM3 fix.  

To allow re-import of hands that are already in your HM3 Database you need to enable "Allow reimport of hand histories" in Tools>Settings>Import.  (Click Here For More Information) Tools > Settings > Import (FAQ)


4. Import Folders (Hand History Folders)

Import Folders lets you manually import hand history files that are stored in a folder. HM3 will open a Windows File Explorer window where you select the hand history folder. Select the folder, then click Open.

Importing hand history folders

HM3 will auto import hand history files as you play poker. The only time you need to manually import hand history files is when:

  • You created a new database.
  • Your poker site sent you old hand history text files.
  • Re-import hands after a HM3 fix.

To allow re-import of hands that are already in your HM3 Database you need to enable "Allow reimport of hand histories" in Tools>Settings>Import. (Click Here For More Information) Tools > Settings > Import (FAQ)


5. Import a HM2 Database

To import an existing HM2 database to your current HM3 database, or to a new HM3 Database, you need to first make sure the HM3 database you want to import to is active. If you want to import to a new database use the File > New Database ... (Ctrl+N) menu. To import to an existing database set the database as active via the File > Open Database... (Ctrl+O) menu.

Next you need to open the File > Import HM2 Database... menu.

Importing a HM2 Database

This will open the following Import HM2 Database window.

  1. Use the Import from: drop-down menu to choose the HM2 database you want to import.
  2. Select the [x] Hero only hands option if you only want to import hand history files that contain known/hero hole cards.
  3. You can use the Date range: filters if you only want to import a date specific sub-set of hands from the HM2 database to HM3.
  4. Select the Import button to import the database, or the Cancel button if you no longer want to import the HM2 database hands to HM3.

After selecting Import from step 4 above HM3 will export the hands from the HM2 database to a temp folder so HM3 can import the hands. The bottom status bar of HM3 will show the progress as it imports hands then runs tournament detection if the database contained tournaments.
Database import process showing time remaining.

After the import and tournament detection finishes you should also run the new Tools - 'Import HM2 Tournament Results...' if your HM2 database had any tournaments that you had manually edited the results of.

Once all database import processes are complete you can review your reports or use the database for live play with the HM3 HUD.

If you see the following screen when trying to import your HM2 database into HM3, this means your HM2 PostgreSQL database is not available for import.  You can still re-create your old HM2 database by importing hands from the HM2 Archive folder.

(Default) HM2 Hand Archive Folder: C:\HM2Archive
(Default) HM3 Hand Archive Folder: C:\HM3Archive

postgresql errors


6. Start/Stop Auto Import

Start and Stop Auto Import will start or stop the HM3 Auto Hand Importing Process.  This is the same as clicking Start or Stop HUD in the main user interface as shown below. 

If you see "Stop HUD", then your hands are auto importing and your HUD is currently active.
If you see "Start HUD", then your hands are not auto importing and your HUD is not active.

Starting and stopping auto hand imports

Auto Import must be running to display a HUD on live tables. 


7. Switch to a Recent Database

If you have multiple HM3 Hand Databases they will be listed here.  Select a different database and HM3 will load the selected HM3 hand database. (Screen below shows three recent HM3 hand databases.)

Switching between databases


Suggested Video Guides

(Video) File Menu

(Video) Database Management

Is this article helpful?
0 0 0